Maven插件之JDK版本选择

2018年12月19日17:45:38 发表评论 268

Maven插件之JDK版本选择前提

基础环境Apache Maven 3.5.0JDK 1.8

概述

Maven插件之JDK版本选择

官网:http://maven.apache.org/plugins/maven-compiler-plugin/index.html

根据官网的说明,目前Apache Maven Compiler Plugin版本更新到了3.8,默认的编译版本为java 1.6

注意Maven 3.5默认使用JDK1.5Maven 3.8默认使用JDK1.6

问题

  1. Eclipse创建Maven项目的时候,JDK版本默认是5,如何更改默认JDK版本?
  2. 每次右键项目名-maven->update project时候,项目JDK环境版本变回5版本,如何使用指定JDK版本?

4 解决方案

4.1   全局

注:此方案适合全局,可以针对该环境下的所有项目生效。

  1. 更改Apache Maven的配置文件MAVEN/conf/settings.xml,加入(修改)如下配置:
  2. 添加完后,在对eclipse进行设置。window->preferences->maven->user settings, user settings那里选择maven安装目录下的settings.xml文件。如下图Maven插件之JDK版本选择
  3. 设置完成后,右键项目->maven->update project, 这样项目的JDK版本即为8版本,而且每次新建maven项目都默认为JDK1.8版本。

4.2   项目

官网地址:http://maven.apache.org/plugins/maven-compiler-plugin/examples/set-compiler-source-and-target.html

注:此方案只在该项目下生效。

  1. 修改项目根目录下的pom.xml,添加(修改)如下内容:
  • 第一种
  • 第二种
  1. 如上二者选其一,设置完成后,右键项目->maven->update project, 这样项目的JDK版本即为8版本。

 

weinxin
微信公众号
分享IT信息技术、北海生活的网站。提供北海本地化的信息技术服务。
路飞

发表评论

:?: :razz: :sad: :evil: :!: :smile: :oops: :grin: :eek: :shock: :???: :cool: :lol: :mad: :twisted: :roll: :wink: :idea: :arrow: :neutral: :cry: :mrgreen: